summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libfishsound')
-rw-r--r--media-libs/libfishsound/Manifest1
-rw-r--r--media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch13
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0.ebuild48
-rw-r--r--media-libs/libfishsound/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/libfishsound/Manifest b/media-libs/libfishsound/Manifest
new file mode 100644
index 000000000000..8ef666905faa
--- /dev/null
+++ b/media-libs/libfishsound/Manifest
@@ -0,0 +1 @@
+DIST libfishsound-1.0.0.tar.gz 444980 SHA256 2e0b57ce2fecc9375eef72938ed08ac8c8f6c5238e1cae24458f0b0e8dade7c7
diff --git a/media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch b/media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch
new file mode 100644
index 000000000000..fa417bb98ef8
--- /dev/null
+++ b/media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch
@@ -0,0 +1,13 @@
+This will avoid including -I/usr/include/FLAC in `pkg-config --cflags fishsound` since
+FLAC/assert.h will collide with system assert.h.
+
+--- fishsound.pc.in
++++ fishsound.pc.in
+@@ -5,7 +5,6 @@
+
+ Name: fishsound
+ Description: Encode and decode Vorbis, Speex, FLAC audio
+-Requires: @fishsound_pkgdeps@
+ Version: @VERSION@
+ Libs: -L${libdir} -lfishsound
+ Libs.private: @VORBIS_LIBS@ @SPEEX_LIBS@ @FLAC_LIBS@
diff --git a/media-libs/libfishsound/libfishsound-1.0.0.ebuild b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
new file mode 100644
index 000000000000..897e70462c48
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
+HOMEPAGE="http://www.xiph.org/fishsound/"
+SRC_URI="http://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="flac speex"
+
+RDEPEND="media-libs/libvorbis
+ media-libs/libogg
+ flac? ( media-libs/flac )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# bug #395153
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pc.patch
+ sed -i \
+ -e 's:doxygen:doxygen-dummy:' \
+ configure || die
+}
+
+src_configure() {
+ local myconf=""
+ use flac || myconf="${myconf} --disable-flac"
+ use speex || myconf="${myconf} --disable-speex"
+
+ econf \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${D}/usr/share/doc/${PF}" install || die
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/media-libs/libfishsound/metadata.xml b/media-libs/libfishsound/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-libs/libfishsound/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>