summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-04-24 04:57:07 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-04-24 04:57:07 +0000
commit8d237b795de8a3e6fb920f5028ffa07f4465c7aa (patch)
tree35241f0a571c5161503e3e6e8284c036c3e976b4 /app-arch/xar/xar-20050423.ebuild
parent~ppc-macos keyword (diff)
downloadhistorical-8d237b795de8a3e6fb920f5028ffa07f4465c7aa.tar.gz
historical-8d237b795de8a3e6fb920f5028ffa07f4465c7aa.tar.bz2
historical-8d237b795de8a3e6fb920f5028ffa07f4465c7aa.zip
initial import.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-arch/xar/xar-20050423.ebuild')
-rw-r--r--app-arch/xar/xar-20050423.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/xar/xar-20050423.ebuild b/app-arch/xar/xar-20050423.ebuild
new file mode 100644
index 000000000000..220b71ad83dc
--- /dev/null
+++ b/app-arch/xar/xar-20050423.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xar/xar-20050423.ebuild,v 1.1 2005/04/24 04:57:07 kito Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The XAR project aims to provide an easily extensible archive format."
+HOMEPAGE="http://www.opendarwin.org/projects/xar/"
+SRC_URI="http://www.opendarwin.org/projects/xar/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ dev-libs/openssl
+ dev-libs/libxml2
+ sys-libs/zlib"
+
+src_compile() {
+ use debug && myconf="${myconf} --enable-symbols"
+ use ppc64 && myconf="${myconf} --enable-64bit"
+ use sparc && myconf="${myconf} --enable-64bit-vis"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}