summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-30 03:00:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-30 03:00:44 +0000
commit55c7b16fa4f70f84c44ccebdf14fa5cd48f9387d (patch)
tree0543e6fa363b1d0769369859e87a0f08c950dcd4 /app-benchmarks
parentAdded to ~sparc and ~amd64. get_libdir support added. (diff)
downloadhistorical-55c7b16fa4f70f84c44ccebdf14fa5cd48f9387d.tar.gz
historical-55c7b16fa4f70f84c44ccebdf14fa5cd48f9387d.tar.bz2
historical-55c7b16fa4f70f84c44ccebdf14fa5cd48f9387d.zip
amd64 fix #65719
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/cpuburn/ChangeLog5
-rw-r--r--app-benchmarks/cpuburn/Manifest10
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4.ebuild7
3 files changed, 15 insertions, 7 deletions
diff --git a/app-benchmarks/cpuburn/ChangeLog b/app-benchmarks/cpuburn/ChangeLog
index b9eee87a80ae..9efc9a7e27fd 100644
--- a/app-benchmarks/cpuburn/ChangeLog
+++ b/app-benchmarks/cpuburn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/cpuburn
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/ChangeLog,v 1.6 2004/06/24 21:27:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/ChangeLog,v 1.7 2004/09/30 03:00:44 vapier Exp $
+
+ 29 Sep 2004; Mike Frysinger <vapier@gentoo.org> cpuburn-1.4.ebuild:
+ Compiled with -m32 on amd64 systems #65719 by Rick Warner.
12 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> cpuburn-1.4.ebuild:
Don't assign default to S; header fix
diff --git a/app-benchmarks/cpuburn/Manifest b/app-benchmarks/cpuburn/Manifest
index 1153060b34eb..67eb9ebc517c 100644
--- a/app-benchmarks/cpuburn/Manifest
+++ b/app-benchmarks/cpuburn/Manifest
@@ -1,13 +1,13 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 194c9c26ab396ce3a8df526b823d74a2 ChangeLog 538
-MD5 9241a9ab168256b99c54554a27c4b6da cpuburn-1.4.ebuild 761
+MD5 f1af8f31a1a363f7339440ecfdd16749 ChangeLog 668
+MD5 e885f880a843884d54fddb81a80e0180 cpuburn-1.4.ebuild 866
MD5 6cf0a4c748c883846c78a58b0173aa80 files/digest-cpuburn-1.4 61
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBSm8FHTu7gpaalycRAo9vAJ9g1i62D/ero/OO5AXf96dEC9Y1hgCeLTwQ
-Nq9S7WekT0ytITPfLOpNzr4=
-=03ja
+iD8DBQFBW3byHTu7gpaalycRAolMAJ9i8CoHaPwnKF2p07n6nH3WHFRhQQCg0w8I
+mQgt1XresnJPe0oW24RnAzM=
+=ZUHL
-----END PGP SIGNATURE-----
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
index 21bbeac4a6bd..c32bb906f3b9 100644
--- a/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
+++ b/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4.ebuild,v 1.8 2004/09/17 04:58:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4.ebuild,v 1.9 2004/09/30 03:00:44 vapier Exp $
MY_P="${PV/./_}"
DESCRIPTION="designed to heavily load CPU chips [testing purposes]"
@@ -20,6 +20,11 @@ src_unpack() {
# for some reason he has it _tar instead of .tar ...
unpack ${A}
tar -xf cpuburn_${MY_P}_tar || die
+
+ if use amd64 ; then #65719
+ cd ${S}
+ sed -i 's:gcc -s:gcc -m32 -s:' Makefile || die "sed failed"
+ fi
}
src_compile() {