summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-31 07:03:43 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-31 07:03:43 +0000
commitb5405265b9d899b796d8a6e494070384efbadf27 (patch)
treeea0eb05e895c1d91ad6b7054d645f45bae07f158 /app-text
parentfixed broken encoding in ChangeLog (diff)
downloadhistorical-b5405265b9d899b796d8a6e494070384efbadf27.tar.gz
historical-b5405265b9d899b796d8a6e494070384efbadf27.tar.bz2
historical-b5405265b9d899b796d8a6e494070384efbadf27.zip
Version bump, remove old broken version, please unmask after some testing
Package-Manager: portage-2.1_rc3-r2
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-bindings/ChangeLog9
-rw-r--r--app-text/poppler-bindings/files/digest-poppler-bindings-0.5.33
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild71
-rw-r--r--app-text/poppler/ChangeLog8
-rw-r--r--app-text/poppler/files/digest-poppler-0.5.33
-rw-r--r--app-text/poppler/poppler-0.5.3.ebuild57
6 files changed, 149 insertions, 2 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index b870059136ca..bb44c7e1e0c1 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.34 2006/05/30 04:14:25 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.35 2006/05/31 07:03:43 genstef Exp $
+
+*poppler-bindings-0.5.3 (31 May 2006)
+
+ 31 May 2006; Stefan Schweizer <genstef@gentoo.org>
+ -files/poppler-0.5.2-qt4-annotation-helper.patch,
+ -poppler-bindings-0.5.2.ebuild, +poppler-bindings-0.5.3.ebuild:
+ Version bump, remove old broken version, please unmask after some testing
30 May 2006; Joseph Jezak <josejx@gentoo.org>
poppler-bindings-0.5.1-r1.ebuild:
diff --git a/app-text/poppler-bindings/files/digest-poppler-bindings-0.5.3 b/app-text/poppler-bindings/files/digest-poppler-bindings-0.5.3
new file mode 100644
index 000000000000..be8336be3bad
--- /dev/null
+++ b/app-text/poppler-bindings/files/digest-poppler-bindings-0.5.3
@@ -0,0 +1,3 @@
+MD5 d06207536555f5711e7bc61711c1b8a0 poppler-0.5.3.tar.gz 1049900
+RMD160 3456de23955fc4001842c76d32deba308bd7f968 poppler-0.5.3.tar.gz 1049900
+SHA256 5cfabff39670610fa8f5c33da7b9b0ae89d445445be6d6c245cdce8bf3f24190 poppler-0.5.3.tar.gz 1049900
diff --git a/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
new file mode 100644
index 000000000000..eabe716a4de7
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild,v 1.1 2006/05/31 07:03:43 genstef Exp $
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="Poppler bindings are rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org"
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt cairo qt4"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-0.5 )
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ )
+ qt? ( =x11-libs/qt-3* )
+ qt4? ( =x11-libs/qt-4* )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/automake-1.9.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/poppler-0.5.2-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+ sed -i s:/usr/lib/qt:/usr/lib/qt4: configure
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf --enable-opi \
+ $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ use cairo && dolib.a poppler/libpoppler-cairo.la
+ make DESTDIR=${D} install || die "make install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index 039f8b08e3df..cbcd4908dc7f 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.87 2006/05/30 04:08:19 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.88 2006/05/31 07:00:16 genstef Exp $
+
+*poppler-0.5.3 (31 May 2006)
+
+ 31 May 2006; Stefan Schweizer <genstef@gentoo.org> -poppler-0.5.2.ebuild,
+ +poppler-0.5.3.ebuild:
+ Version bump, remove old broken version, please unmask after some testing
30 May 2006; Joseph Jezak <josejx@gentoo.org> poppler-0.5.1-r1.ebuild:
Marked ppc stable.
diff --git a/app-text/poppler/files/digest-poppler-0.5.3 b/app-text/poppler/files/digest-poppler-0.5.3
new file mode 100644
index 000000000000..be8336be3bad
--- /dev/null
+++ b/app-text/poppler/files/digest-poppler-0.5.3
@@ -0,0 +1,3 @@
+MD5 d06207536555f5711e7bc61711c1b8a0 poppler-0.5.3.tar.gz 1049900
+RMD160 3456de23955fc4001842c76d32deba308bd7f968 poppler-0.5.3.tar.gz 1049900
+SHA256 5cfabff39670610fa8f5c33da7b9b0ae89d445445be6d6c245cdce8bf3f24190 poppler-0.5.3.tar.gz 1049900
diff --git a/app-text/poppler/poppler-0.5.3.ebuild b/app-text/poppler/poppler-0.5.3.ebuild
new file mode 100644
index 000000000000..fcd5eb450720
--- /dev/null
+++ b/app-text/poppler/poppler-0.5.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.5.3.ebuild,v 1.1 2006/05/31 07:00:16 genstef Exp $
+
+inherit flag-o-matic eutils libtool
+
+DESCRIPTION="Poppler is a PDF rendering library based on the xpdf-3.0 code base."
+HOMEPAGE="http://poppler.freedesktop.org"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="jpeg"
+
+RDEPEND=">=media-libs/freetype-2.1.8
+ media-libs/fontconfig
+ jpeg? ( >=media-libs/jpeg-6b )
+ !app-text/pdftohtml"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/automake-1.9.6"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ # -Os is broken, see bug 124179
+ replace-flags -Os -O2
+
+ econf --disable-poppler-qt4 \
+ --disable-poppler-glib \
+ --disable-poppler-qt \
+ --disable-gtk-test \
+ --enable-opi \
+ --disable-cairo-output \
+ --enable-xpdf-headers \
+ $(use_enable jpeg libjpeg) \
+ || die "configuration failed"
+ # $(use_enable zlib) breaks, see
+ # https://bugs.freedesktop.org/show_bug.cgi?id=3948
+ emake || die "compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README AUTHORS ChangeLog NEWS README-XPDF TODO pdf2xml.dtd
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}