summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-08-24 04:01:13 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-08-24 04:01:13 +0000
commitd5ca705bbd81ccbff48b264b20ec71851a8b2fbe (patch)
tree0058350b2de38678f08806a41b6ea401e19bf96f /dev-java/commons-net
parentUse epatch for patching and removed RDEPEND="${DEPEND}" (diff)
downloadhistorical-d5ca705bbd81ccbff48b264b20ec71851a8b2fbe.tar.gz
historical-d5ca705bbd81ccbff48b264b20ec71851a8b2fbe.tar.bz2
historical-d5ca705bbd81ccbff48b264b20ec71851a8b2fbe.zip
Cleanup & Marking x86
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/ChangeLog6
-rw-r--r--dev-java/commons-net/commons-net-1.1.0.ebuild33
-rw-r--r--dev-java/commons-net/commons-net-1.2.0.ebuild36
-rw-r--r--dev-java/commons-net/commons-net-1.2.2.ebuild4
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.1.01
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.2.01
6 files changed, 7 insertions, 74 deletions
diff --git a/dev-java/commons-net/ChangeLog b/dev-java/commons-net/ChangeLog
index cd5977a34027..2c7536aff1f9 100644
--- a/dev-java/commons-net/ChangeLog
+++ b/dev-java/commons-net/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-net
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.12 2004/07/23 21:00:28 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.13 2004/08/24 03:58:14 zx Exp $
+
+ 23 Aug 2004; Chris Aniszczyk <zx@gentoo.org> -commons-net-1.1.0.ebuild,
+ -commons-net-1.2.0.ebuild, commons-net-1.2.2.ebuild:
+ Cleanup & Marking x86
23 Jul 2004; Thomas Matthijs <axxo@gentoo.org> commons-net-1.1.0.ebuild,
commons-net-1.2.0.ebuild, commons-net-1.2.2.ebuild:
diff --git a/dev-java/commons-net/commons-net-1.1.0.ebuild b/dev-java/commons-net/commons-net-1.1.0.ebuild
deleted file mode 100644
index 2904eeedee4d..000000000000
--- a/dev-java/commons-net/commons-net-1.1.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.1.0.ebuild,v 1.8 2004/07/23 21:00:28 axxo Exp $
-
-inherit eutils java-pkg
-
-DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
-HOMEPAGE="http://jakarta.apache.org/commons/net/index.html"
-SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.5.4
- >=dev-java/oro-2.0.7"
-RDEPEND=">=virtual/jdk-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="jikes"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/gentoo.diff
-}
-
-src_compile() {
- local antflags="-Doro.jar=$(java-config -p oro) jar"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- ant ${antflags} || die "died on ant"
-}
-
-src_install() {
- java-pkg_dojar target/*.jar || die "died on java-pkg_dojar"
-}
diff --git a/dev-java/commons-net/commons-net-1.2.0.ebuild b/dev-java/commons-net/commons-net-1.2.0.ebuild
deleted file mode 100644
index b4b01c8ee70b..000000000000
--- a/dev-java/commons-net/commons-net-1.2.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.0.ebuild,v 1.3 2004/07/23 21:00:28 axxo Exp $
-
-inherit eutils java-pkg
-
-DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
-HOMEPAGE="http://jakarta.apache.org/commons/net/"
-SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.5.4
- >=dev-java/oro-2.0.7"
-RDEPEND=">=virtual/jdk-1.3"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="jikes doc"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/gentoo-1.2.diff
-}
-
-src_compile() {
- local antflags="-Doro.jar=$(java-config -p oro) jar"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- use doc && antflags="${antflags} javadoc"
- ant ${antflags} || die "died on ant"
-}
-
-src_install() {
- mv ${S}/target/${P}-dev.jar ${S}/target/${PN}.jar
- java-pkg_dojar target/${PN}.jar || die "died on java-pkg_dojar"
- use doc && dohtml -r dist/docs/
-}
diff --git a/dev-java/commons-net/commons-net-1.2.2.ebuild b/dev-java/commons-net/commons-net-1.2.2.ebuild
index 1a681da7a657..b5c408ab4663 100644
--- a/dev-java/commons-net/commons-net-1.2.2.ebuild
+++ b/dev-java/commons-net/commons-net-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.2.ebuild,v 1.4 2004/07/26 19:10:46 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.2.ebuild,v 1.5 2004/08/24 03:58:14 zx Exp $
inherit eutils java-pkg
@@ -13,7 +13,7 @@ DEPEND=">=virtual/jdk-1.3
RDEPEND=">=virtual/jdk-1.3"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86 ~sparc ~ppc ~amd64"
IUSE="jikes doc"
src_unpack() {
diff --git a/dev-java/commons-net/files/digest-commons-net-1.1.0 b/dev-java/commons-net/files/digest-commons-net-1.1.0
deleted file mode 100644
index 20f3f86224b2..000000000000
--- a/dev-java/commons-net/files/digest-commons-net-1.1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e54d771b56b19085991cb9fcff7f5187 commons-net-1.1.0-src.tar.gz 178397
diff --git a/dev-java/commons-net/files/digest-commons-net-1.2.0 b/dev-java/commons-net/files/digest-commons-net-1.2.0
deleted file mode 100644
index 9000d7304640..000000000000
--- a/dev-java/commons-net/files/digest-commons-net-1.2.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f63a734433821a6836c4a62daf117c27 commons-net-1.2.0-src.tar.gz 179936