summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 21:29:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 21:29:35 +0000
commitcb653481f9a67a21751d272d9df3480dfac6b0c1 (patch)
tree087ccd8a8008b10543ade7c621b1adc70327fb7a /dev-python
parentfixing Manifest (diff)
downloadhistorical-cb653481f9a67a21751d272d9df3480dfac6b0c1.tar.gz
historical-cb653481f9a67a21751d272d9df3480dfac6b0c1.tar.bz2
historical-cb653481f9a67a21751d272d9df3480dfac6b0c1.zip
add inherit eutils
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild15
-rw-r--r--dev-python/PyQt/PyQt-3.10.ebuild9
-rw-r--r--dev-python/PyQt/PyQt-3.8.1.ebuild12
-rw-r--r--dev-python/bsddb3/bsddb3-4.1.3.ebuild10
-rw-r--r--dev-python/bsddb3/bsddb3-4.2.4.ebuild10
-rw-r--r--dev-python/csv/csv-1.0-r1.ebuild9
-rw-r--r--dev-python/docutils/docutils-0.3-r1.ebuild5
-rw-r--r--dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild10
-rw-r--r--dev-python/pyds/pyds-0.6.5.ebuild8
-rw-r--r--dev-python/pyds/pyds-0.7.0.ebuild8
-rw-r--r--dev-python/pygtkglext/pygtkglext-1.0.1.ebuild17
-rw-r--r--dev-python/pyopenal/pyopenal-0.1.3.ebuild12
-rw-r--r--dev-python/pyro/pyro-3.3.ebuild21
-rw-r--r--dev-python/python-xlib/python-xlib-0.12-r1.ebuild13
14 files changed, 77 insertions, 82 deletions
diff --git a/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild b/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild
index b3c92b192b3d..d2d6cacf0885 100644
--- a/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild
+++ b/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild
@@ -1,22 +1,21 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild,v 1.4 2003/10/30 09:49:10 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Imaging-py21/Imaging-py21-1.1.4.ebuild,v 1.5 2004/04/25 21:09:06 vapier Exp $
PYTHON_SLOT_VERSION="2.1"
-inherit distutils
+inherit distutils eutils
P_NEW="${PN%-py21}-${PV}"
S="${WORKDIR}/${P_NEW}"
-IUSE="tcltk"
-
DESCRIPTION="Python Imaging Library (PIL)."
HOMEPAGE="http://www.pythonware.com/products/pil/index.htm"
SRC_URI="http://www.effbot.org/downloads/${P_NEW}.tar.gz"
+LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ~sparc ~alpha ~ppc"
-LICENSE="as-is"
+IUSE="tcltk"
DEPEND=">=media-libs/jpeg-6a
>=sys-libs/zlib-0.95
@@ -45,8 +44,7 @@ src_compile() {
#CFLAGS="$(CFLAGS) -DUSE_COMPOSITELESS_PHOTO_PUT_BLOCK" distutils_src_compile
}
-src_install ()
-{
+src_install() {
local mydoc="CHANGES* CONTENTS"
distutils_src_install
distutils_python_version
@@ -57,4 +55,3 @@ src_install ()
doins libImaging/ImPlatform.h
doins libImaging/ImConfig.h
}
-
diff --git a/dev-python/PyQt/PyQt-3.10.ebuild b/dev-python/PyQt/PyQt-3.10.ebuild
index c48fcc5949fe..630f28f401dc 100644
--- a/dev-python/PyQt/PyQt-3.10.ebuild
+++ b/dev-python/PyQt/PyQt-3.10.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.3 2004/03/14 21:09:52 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.10.ebuild,v 1.4 2004/04/25 21:09:26 vapier Exp $
-inherit distutils
+inherit distutils eutils
-IUSE=""
MY_P="PyQt-x11-gpl-${PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE=""
PV_MAJOR=${PV/.*/}
PV_MINOR=${PV#${PV_MAJOR}.}
PV_MINOR=${PV_MINOR/.*}
diff --git a/dev-python/PyQt/PyQt-3.8.1.ebuild b/dev-python/PyQt/PyQt-3.8.1.ebuild
index aafb2d2cfb3a..687546661cd5 100644
--- a/dev-python/PyQt/PyQt-3.8.1.ebuild
+++ b/dev-python/PyQt/PyQt-3.8.1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.6 2004/03/03 21:37:46 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.7 2004/04/25 21:10:05 vapier Exp $
-inherit distutils
-
-IUSE=""
+inherit distutils eutils
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
SRC_URI="mirror://gentoo/PyQt-x11-gpl-${PV}.tar.gz"
#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc sparc ~alpha"
+IUSE=""
PV_MAJOR=${PV/.*/}
PV_MINOR=${PV#${PV_MAJOR}.}
diff --git a/dev-python/bsddb3/bsddb3-4.1.3.ebuild b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
index 8245008aa134..fd81bb494e0b 100644
--- a/dev-python/bsddb3/bsddb3-4.1.3.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.8 2004/03/30 08:00:16 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.9 2004/04/25 21:10:25 vapier Exp $
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Python bindings for BerkeleyDB"
HOMEPAGE="http://pybsddb.sourceforge.net/"
SRC_URI="mirror://sourceforge/pybsddb/${P}.tar.gz"
-LICENSE="BSD"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~amd64"
IUSE=""
@@ -20,7 +20,8 @@ DOCS="README.txt TODO.txt"
src_unpack() {
unpack ${A}
- cd ${S}; epatch ${FILESDIR}/${P}-db4.0.patch
+ cd ${S}
+ epatch ${FILESDIR}/${P}-db4.0.patch
}
src_compile() {
@@ -31,4 +32,3 @@ src_install() {
distutils_src_install "--berkeley-db=/usr"
dohtml docs/*
}
-
diff --git a/dev-python/bsddb3/bsddb3-4.2.4.ebuild b/dev-python/bsddb3/bsddb3-4.2.4.ebuild
index 1f07d1807c62..0f5c61d24f9b 100644
--- a/dev-python/bsddb3/bsddb3-4.2.4.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.2.4.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.2.4.ebuild,v 1.3 2004/03/17 09:44:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.2.4.ebuild,v 1.4 2004/04/25 21:14:18 vapier Exp $
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Python bindings for BerkeleyDB"
HOMEPAGE="http://pybsddb.sourceforge.net/"
SRC_URI="mirror://sourceforge/pybsddb/${P}.tar.gz"
-LICENSE="BSD"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86" # ~ppc ~sparc"
IUSE=""
@@ -20,7 +20,8 @@ DOCS="README.txt TODO.txt"
src_unpack() {
unpack ${A}
- cd ${S}; epatch ${FILESDIR}/${P}-db4.2.patch
+ cd ${S}
+ epatch ${FILESDIR}/${P}-db4.2.patch
}
src_compile() {
@@ -31,4 +32,3 @@ src_install() {
distutils_src_install "--berkeley-db=/usr"
dohtml docs/*
}
-
diff --git a/dev-python/csv/csv-1.0-r1.ebuild b/dev-python/csv/csv-1.0-r1.ebuild
index 1494096ba437..cd5156814027 100644
--- a/dev-python/csv/csv-1.0-r1.ebuild
+++ b/dev-python/csv/csv-1.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/csv/csv-1.0-r1.ebuild,v 1.3 2004/02/16 20:51:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/csv/csv-1.0-r1.ebuild,v 1.4 2004/04/25 21:16:21 vapier Exp $
-inherit distutils
+inherit distutils eutils
DESCRIPTION="CSV Module for Python"
HOMEPAGE="http://www.object-craft.com.au/projects/csv/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.object-craft.com.au/projects/csv/download/${P}.tar.gz"
LICENSE="PYTHON"
SLOT="0"
-KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
IUSE=""
pkg_setup() {
@@ -21,5 +21,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
# patch thanks to David Grant <david.grant@telus.net> (#40429)
- cd ${S}; epatch ${FILESDIR}/${P}-rename.patch
+ cd ${S}
+ epatch ${FILESDIR}/${P}-rename.patch
}
diff --git a/dev-python/docutils/docutils-0.3-r1.ebuild b/dev-python/docutils/docutils-0.3-r1.ebuild
index 6e27543cca19..b21d63846ff0 100644
--- a/dev-python/docutils/docutils-0.3-r1.ebuild
+++ b/dev-python/docutils/docutils-0.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.3-r1.ebuild,v 1.5 2004/03/27 10:37:52 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.3-r1.ebuild,v 1.6 2004/04/25 21:20:56 vapier Exp $
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Set of python tools for processing plaintext docs into HTML, XML, etc."
HOMEPAGE="http://docutils.sourceforge.net/"
@@ -67,4 +67,3 @@ src_install() {
insinto /usr/lib/python${PYVER}/site-packages/docutils/writers
newins ${GLEP_SRC}/glep_htmlwrite.py glep_html.py
}
-
diff --git a/dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild b/dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild
index b814482568ad..72d410727a50 100644
--- a/dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild
+++ b/dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild,v 1.9 2004/02/19 14:19:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kinterbasdb/kinterbasdb-3.0.2.ebuild,v 1.10 2004/04/25 21:24:34 vapier Exp $
-inherit distutils
+inherit distutils eutils
-DESCRIPTION="kinterbasdb - firebird/interbase interface for Python."
+DESCRIPTION="firebird/interbase interface for Python"
+HOMEPAGE="http://kinterbasdb.sourceforge.net/"
SRC_URI="mirror://sourceforge/kinterbasdb/${P}-src.tar.gz"
-HOMEPAGE="http://kinterbasdb.sourceforge.net"
-IUSE=""
LICENSE="kinterbasdb"
SLOT="0"
KEYWORDS="x86 -sparc"
+IUSE=""
DEPEND="dev-lang/python
>=dev-db/firebird-1.0_rc1
diff --git a/dev-python/pyds/pyds-0.6.5.ebuild b/dev-python/pyds/pyds-0.6.5.ebuild
index b17f58f86bee..bf7d5f0aaa71 100644
--- a/dev-python/pyds/pyds-0.6.5.ebuild
+++ b/dev-python/pyds/pyds-0.6.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.6.5.ebuild,v 1.4 2004/02/16 20:50:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.6.5.ebuild,v 1.5 2004/04/25 21:26:57 vapier Exp $
-inherit distutils
+inherit distutils eutils
MY_P="PyDS-${PV}"
@@ -10,9 +10,9 @@ DESCRIPTION="Python Desktop Server"
HOMEPAGE="http://pyds.muensterland.org/"
SRC_URI="http://simon.bofh.ms/~gb/${MY_P}.tar.gz"
-KEYWORDS="~x86"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
IUSE=""
RDEPEND="media-libs/jpeg
diff --git a/dev-python/pyds/pyds-0.7.0.ebuild b/dev-python/pyds/pyds-0.7.0.ebuild
index e73318bc807c..309a13012b06 100644
--- a/dev-python/pyds/pyds-0.7.0.ebuild
+++ b/dev-python/pyds/pyds-0.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.7.0.ebuild,v 1.4 2004/04/19 05:39:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds/pyds-0.7.0.ebuild,v 1.5 2004/04/25 21:27:56 vapier Exp $
-inherit distutils
+inherit distutils eutils
MY_P="PyDS-${PV}"
@@ -10,9 +10,9 @@ DESCRIPTION="Python Desktop Server"
HOMEPAGE="http://pyds.muensterland.org/"
SRC_URI="http://simon.bofh.ms/~gb/${MY_P}.tar.gz"
-KEYWORDS="~x86"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
IUSE=""
RDEPEND="media-libs/jpeg
diff --git a/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild b/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
index 39abdf0a8ba7..a2ae30a0a62a 100644
--- a/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
+++ b/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild,v 1.3 2004/02/14 12:45:22 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkglext/pygtkglext-1.0.1.ebuild,v 1.4 2004/04/25 21:28:17 vapier Exp $
-inherit python
+inherit python eutils
DESCRIPTION="Python bindings to GtkGLExt"
HOMEPAGE="http://gtkglext.sourceforge.net/"
SRC_URI="mirror://sourceforge/gtkglext/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND=">=dev-lang/python-2.2.3-r3
>=dev-python/pygtk-2
>=dev-libs/glib-2.0
@@ -24,17 +25,13 @@ DEPEND=">=dev-lang/python-2.2.3-r3
src_unpack() {
unpack ${A}
- cd ${S}; epatch ${FILESDIR}/${P}-gentoo.diff
-}
-
-src_compile() {
- econf
- emake || die
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
}
src_install() {
make DESTDIR=${D} install || die
- dodoc README COPYING* AUTHORS ChangeLog
+ dodoc README AUTHORS ChangeLog
insinto /usr/share/doc/${PF}/examples
doins examples/*.py
}
diff --git a/dev-python/pyopenal/pyopenal-0.1.3.ebuild b/dev-python/pyopenal/pyopenal-0.1.3.ebuild
index d4a339cb7cf7..f5deead45897 100644
--- a/dev-python/pyopenal/pyopenal-0.1.3.ebuild
+++ b/dev-python/pyopenal/pyopenal-0.1.3.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopenal/pyopenal-0.1.3.ebuild,v 1.4 2004/04/01 02:20:17 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopenal/pyopenal-0.1.3.ebuild,v 1.5 2004/04/25 21:28:35 vapier Exp $
-inherit distutils
+inherit distutils eutils
-IUSE=""
MY_P=${P/pyopenal/PyOpenAL}
DESCRIPTION="OpenAL library port for Python"
+HOMEPAGE="http://oomadness.tuxfamily.org/en/pyopenal/"
SRC_URI="http://oomadness.tuxfamily.org/downloads/${MY_P}.tar.gz
http://www.nectroom.homelinux.net/pkg/${MY_P}.tar.gz
http://nectroom.homelinux.net/pkg/${MY_P}.tar.gz"
-HOMEPAGE="http://oomadness.tuxfamily.org/en/pyopenal/"
-KEYWORDS="x86 ~ppc"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
DEPEND=">=dev-lang/python-2.2.2
media-libs/openal
diff --git a/dev-python/pyro/pyro-3.3.ebuild b/dev-python/pyro/pyro-3.3.ebuild
index 7f86ddb3aa39..e616112dee73 100644
--- a/dev-python/pyro/pyro-3.3.ebuild
+++ b/dev-python/pyro/pyro-3.3.ebuild
@@ -1,28 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.3.ebuild,v 1.2 2004/02/17 00:42:04 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.3.ebuild,v 1.3 2004/04/25 21:29:17 vapier Exp $
-inherit distutils
-
-DESCRIPTION="Pyro is an advanced and powerful Distributed Object Technology system written entirely in Python"
+inherit distutils eutils
MY_P="Pyro-${PV}"
-S=${WORKDIR}/${MY_P}
-HOMEPAGE="http://pyro.sourceforge.net"
-LICENSE="MIT"
+DESCRIPTION="advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://pyro.sourceforge.net/"
SRC_URI="mirror://sourceforge/pyro/${MY_P}.tar.gz"
-DEPEND="virtual/python"
+LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-src_unpack () {
+DEPEND="virtual/python"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-unattend.patch
}
-src_install () {
+src_install() {
distutils_src_install
dodir /usr/share/doc/${PF}/examples
diff --git a/dev-python/python-xlib/python-xlib-0.12-r1.ebuild b/dev-python/python-xlib/python-xlib-0.12-r1.ebuild
index ea32ecc70d8b..27570fa8616c 100644
--- a/dev-python/python-xlib/python-xlib-0.12-r1.ebuild
+++ b/dev-python/python-xlib/python-xlib-0.12-r1.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.12-r1.ebuild,v 1.2 2004/04/03 06:10:31 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.12-r1.ebuild,v 1.3 2004/04/25 21:29:35 vapier Exp $
-inherit distutils
+inherit distutils eutils
-S=${WORKDIR}/${P}
-DESCRIPTION="A fully functional X client library for Python, written in Python."
-SRC_URI="mirror://sourceforge/python-xlib/${P}.tar.gz"
+DESCRIPTION="A fully functional X client library for Python, written in Python"
HOMEPAGE="http://python-xlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/python-xlib/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ia64"
IUSE=""
src_install () {
- epatch "${FILESDIR}/${P}-info.patch"
+ epatch ${FILESDIR}/${P}-info.patch
mydoc="doc/ps/python-xlib.ps PKG-INFO TODO"
distutils_src_install
dohtml -r doc/html/