summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-12 02:58:43 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-12 02:58:43 +0000
commita5530e9f304a18463814f5f0285dbbd6523967b5 (patch)
tree23f59982aecec7d4ed59be7c88d213b8c00ccb5a /media-plugins/xmms-cdaudio
parentUpdated to work with new aolserver.eclass changes (diff)
downloadhistorical-a5530e9f304a18463814f5f0285dbbd6523967b5.tar.gz
historical-a5530e9f304a18463814f5f0285dbbd6523967b5.tar.bz2
historical-a5530e9f304a18463814f5f0285dbbd6523967b5.zip
Fix global scope use_enable.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'media-plugins/xmms-cdaudio')
-rw-r--r--media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild8
-rw-r--r--media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
index c9b1432e8fbb..7003a242a9a9 100644
--- a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
+++ b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild,v 1.1 2005/02/12 02:26:04 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild,v 1.2 2005/02/12 02:58:43 eradicator Exp $
IUSE="ipv6"
SLOT="0"
@@ -12,7 +12,11 @@ PATCH_VER="2.2.2"
PLUGIN_PATH="Input/cdaudio"
-myconf="--enable-cdaudio `use_enable ipv6`"
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-cdaudio $(use_enable ipv6)"
+ xmms-plugin_src_compile
+}
diff --git a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild
index 22e16eecb6ab..3282b4f4f03b 100644
--- a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild
+++ b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild,v 1.1 2005/02/12 02:26:04 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild,v 1.2 2005/02/12 02:58:43 eradicator Exp $
IUSE="ipv6"
SLOT="0"
@@ -10,7 +10,11 @@ DEPEND=">=media-sound/xmms-1.2.10"
PLUGIN_PATH="Input/cdaudio"
-myconf="--enable-cdaudio `use_enable ipv6`"
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-cdaudio $(use_enable ipv6)"
+ xmms-plugin_src_compile
+}