summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-09 21:44:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-09 21:44:11 +0000
commit875db44a42f2c6cbe09e8ab57aa47698d9e4d804 (patch)
treea50bebaf94ddf0b4d58b9d794760c4871d994a59 /media-sound/paman
parent09 Oct 2008; Zac Medico <zmedico@gentoo.org> +portage-2.2_rc12.ebuild: (diff)
downloadhistorical-875db44a42f2c6cbe09e8ab57aa47698d9e4d804.tar.gz
historical-875db44a42f2c6cbe09e8ab57aa47698d9e4d804.tar.bz2
historical-875db44a42f2c6cbe09e8ab57aa47698d9e4d804.zip
Update to EAPI=2 and USE deps.
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'media-sound/paman')
-rw-r--r--media-sound/paman/ChangeLog7
-rw-r--r--media-sound/paman/paman-0.9.4-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/media-sound/paman/ChangeLog b/media-sound/paman/ChangeLog
index 0e4beb25c8f4..b1b0485274c1 100644
--- a/media-sound/paman/ChangeLog
+++ b/media-sound/paman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/paman
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/paman/ChangeLog,v 1.13 2008/02/11 04:01:39 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/paman/ChangeLog,v 1.14 2008/10/09 21:39:25 flameeyes Exp $
+
+*paman-0.9.4-r1 (09 Oct 2008)
+
+ 09 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> +paman-0.9.4-r1.ebuild:
+ Update to EAPI=2 and USE deps.
11 Feb 2008; Olivier Crête <tester@gentoo.org> paman-0.9.4.ebuild:
Stable on amd64, bug #204219
diff --git a/media-sound/paman/paman-0.9.4-r1.ebuild b/media-sound/paman/paman-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..53922423526c
--- /dev/null
+++ b/media-sound/paman/paman-0.9.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/paman/paman-0.9.4-r1.ebuild,v 1.1 2008/10/09 21:39:25 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Pulseaudio Manager, a simple GTK frontend for Pulseaudio"
+HOMEPAGE="http://0pointer.de/lennart/projects/paman/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+DEPEND=">=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libglademm-2.4
+ >=media-sound/pulseaudio-0.9.5[glib]"
+RDEPEND="${DEPEND}
+ x11-themes/gnome-icon-theme"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # Lynx is used during make dist basically
+ econf \
+ --disable-lynx || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dohtml -r doc
+ dodoc README
+}