summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-10-20 18:40:14 +0000
committerIan Leitch <port001@gentoo.org>2003-10-20 18:40:14 +0000
commit2af79d3639967caa8a030a188a859ba2a1eaa3f2 (patch)
tree96928ba61f888291a000669f16e6743681fbb2f1 /net-analyzer/siphon
parentnew package, #22181 (diff)
downloadhistorical-2af79d3639967caa8a030a188a859ba2a1eaa3f2.tar.gz
historical-2af79d3639967caa8a030a188a859ba2a1eaa3f2.tar.bz2
historical-2af79d3639967caa8a030a188a859ba2a1eaa3f2.zip
new package, #22181
Diffstat (limited to 'net-analyzer/siphon')
-rw-r--r--net-analyzer/siphon/Manifest4
-rw-r--r--net-analyzer/siphon/files/digest-siphon-6661
-rw-r--r--net-analyzer/siphon/metadata.xml26
-rw-r--r--net-analyzer/siphon/siphon-666.ebuild37
4 files changed, 67 insertions, 1 deletions
diff --git a/net-analyzer/siphon/Manifest b/net-analyzer/siphon/Manifest
index ae3fd8ea6bc8..44ccb4872a26 100644
--- a/net-analyzer/siphon/Manifest
+++ b/net-analyzer/siphon/Manifest
@@ -1,2 +1,4 @@
-MD5 c25e4ed74ea9cf671d6faf4cd76ce933 siphon-666.ebuild 637
+MD5 4aa5b1a5ddf3eba1a1716b44b477299d siphon-666.ebuild 738
+MD5 3ea7e0c9cd515759a26c1deff0ece65a ChangeLog 334
+MD5 76f88e9c80369661e8e1d0e8a87805cc metadata.xml 1335
MD5 330e3afc0b46d6b4c991352efa731333 files/digest-siphon-666 62
diff --git a/net-analyzer/siphon/files/digest-siphon-666 b/net-analyzer/siphon/files/digest-siphon-666
new file mode 100644
index 000000000000..2b2f3f7a9dcf
--- /dev/null
+++ b/net-analyzer/siphon/files/digest-siphon-666
@@ -0,0 +1 @@
+MD5 064c63e738235626aeb7820241ce478b siphon-v.666.tar.gz 6951
diff --git a/net-analyzer/siphon/metadata.xml b/net-analyzer/siphon/metadata.xml
new file mode 100644
index 000000000000..849b36e70aeb
--- /dev/null
+++ b/net-analyzer/siphon/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>noherd</herd>
+<maintainer>
+ <email>port001@gentoo.org</email>
+ <name>Ian Leitch</name>
+</maintainer>
+<longdescription>
+The Siphon Project is a portable passive network mapping suite.
+In the latest public version, Siphon passively maps TCP ports
+and performs passive operating system detection.
+Through the magic of RFC ambiguity and programmer uniqueness, different
+machines exhibit telltale characteristics that enable Siphon to make a fairly
+accurate guess at what operating system is running on machines sending packets
+out over the wire. The beauty of this method is that our tool does not need
+to send out a slew of non-RFC compliant packets that trip intrusion detection
+systems. In fact, we send out no packets at all. Whereas nmap crashes some
+machines and network hardware when performing its active OS detection tests,
+Siphon would never crash remote machines. This tool could be used on active
+production networks to detect that a Linux machine suddenly appeared in your
+all Sun shop. As a side note, if used in conjunction with firewalling arp on
+the machine you run Siphon from, it will be difficult to detect.
+Siphon is available for UNIX and Win32.
+</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/siphon/siphon-666.ebuild b/net-analyzer/siphon/siphon-666.ebuild
new file mode 100644
index 000000000000..a346abaf25ec
--- /dev/null
+++ b/net-analyzer/siphon/siphon-666.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/siphon/siphon-666.ebuild,v 1.1 2003/10/20 18:40:10 port001 Exp $
+
+IUSE=""
+MY_P=${PN}-v.${PV}
+
+DESCRIPTION="A portable passive network mapping suite"
+SRC_URI="http://siphon.datanerds.net/${MY_P}.tar.gz"
+HOMEPAGE="http://siphon.datanerds.net/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ sed -i "s:osprints\.conf:/etc/osprints.conf:" log.c
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin siphon
+ insinto /etc
+ doins osprints.conf
+ dodoc LICENSE README
+}
+