aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-01-13 20:45:09 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-01-13 20:59:33 +0900
commitcb3da683f669f8bbdae6b1f51ab4fed59818801d (patch)
treef148ed209445e8a4f63c5fdd76f74f6815537ac8 /gui-apps/corepdf
parentgui-apps/corepaint: add 4.5.0, live sync (diff)
downloadguru-cb3da683f669f8bbdae6b1f51ab4fed59818801d.tar.gz
guru-cb3da683f669f8bbdae6b1f51ab4fed59818801d.tar.bz2
guru-cb3da683f669f8bbdae6b1f51ab4fed59818801d.zip
gui-apps/corepdf: add 4.5.0, live sync
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'gui-apps/corepdf')
-rw-r--r--gui-apps/corepdf/Manifest1
-rw-r--r--gui-apps/corepdf/corepdf-4.5.0.ebuild31
-rw-r--r--gui-apps/corepdf/corepdf-9999.ebuild19
3 files changed, 39 insertions, 12 deletions
diff --git a/gui-apps/corepdf/Manifest b/gui-apps/corepdf/Manifest
index 12d56f809..ac9ad462e 100644
--- a/gui-apps/corepdf/Manifest
+++ b/gui-apps/corepdf/Manifest
@@ -1 +1,2 @@
DIST corepdf-4.2.0.tar.gz 85521 BLAKE2B 348b546ef936c1b5c04cfdefb12dec30331f903f6d40d1b5594f9f07621247244cbd80cab783a2861d4f27b89f7c1c8fe2712ef2b6a9b596687d38ae99e23c0c SHA512 77bb85ec059fe0778e5e506842d84e38f941f587ab303f1526ab52d35d6588039c7c320a001128d81aa394c1a2e817e8af36b3fca4a5c46148acaf64178c9e85
+DIST corepdf-v4.5.0.tar.bz2 86846 BLAKE2B 74f276978bfae652b95bf065317723996a72dd921e68451e45d00db53733695d802419c38ee4798f6e8386fcd24cdd00863edc031f4f90ef11bcb4b37f52ec65 SHA512 f2a6a50d5f42d9aad0c2070e3a36f060a397147819eb9ebd460aaca4ba4df536202ecb6f2905858344d246866baa9c1757f7524527d8fbdd0cf8c9b241bd85fb
diff --git a/gui-apps/corepdf/corepdf-4.5.0.ebuild b/gui-apps/corepdf/corepdf-4.5.0.ebuild
new file mode 100644
index 000000000..1fe8d8246
--- /dev/null
+++ b/gui-apps/corepdf/corepdf-4.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="A PDF viewer for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepdf"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/corepdf.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/corepdf/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ app-text/poppler[qt5]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="${DEPEND}"
diff --git a/gui-apps/corepdf/corepdf-9999.ebuild b/gui-apps/corepdf/corepdf-9999.ebuild
index 0ebca7da3..1fe8d8246 100644
--- a/gui-apps/corepdf/corepdf-9999.ebuild
+++ b/gui-apps/corepdf/corepdf-9999.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-MY_PV="${PV/_/-}"
+EAPI=8
inherit xdg cmake
@@ -12,25 +10,22 @@ HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepdf"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/corepdf.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/corepdf/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${MY_PV}"
+ S="${WORKDIR}/${PN}-v${PV}"
fi
-RESTRICT="test"
LICENSE="GPL-3"
SLOT="0"
DEPEND="
app-text/poppler[qt5]
- dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
gui-libs/libcprime
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"