summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-02 05:50:24 +0100
committerSam James <sam@gentoo.org>2021-07-02 05:50:44 +0100
commit1c3eb3b0aeb7e3600297b21f3495f1f6f21b1702 (patch)
tree6e5329c8b331cfc7d51300c12063b2c3ec3b99fa /dev-libs/botan
parentnet-misc/iperf: don't force -g (diff)
downloadgentoo-1c3eb3b0aeb7e3600297b21f3495f1f6f21b1702.tar.gz
gentoo-1c3eb3b0aeb7e3600297b21f3495f1f6f21b1702.tar.bz2
gentoo-1c3eb3b0aeb7e3600297b21f3495f1f6f21b1702.zip
dev-libs/botan: use correct Python implementation for build (fix -native-symlinks)
As per the Python guide [0], we can call python_setup for additional build-time usage. We also use ${EPYTHON} to call configure.py instead of relying on the shebang and possible python-exec magic. (The configure script passes on the executable it was called with for later use too.) [0] https://dev.gentoo.org/~mgorny/python-guide/multi.html#additional-build-time-python-use Closes: https://bugs.gentoo.org/765631 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/botan-2.17.3-r1.ebuild4
-rw-r--r--dev-libs/botan/botan-2.18.1-r1.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-2.17.3-r1.ebuild b/dev-libs/botan/botan-2.17.3-r1.ebuild
index 2bb63cd2ae79..9900e923b2a8 100644
--- a/dev-libs/botan/botan-2.17.3-r1.ebuild
+++ b/dev-libs/botan/botan-2.17.3-r1.ebuild
@@ -53,6 +53,8 @@ python_check_deps() {
}
src_configure() {
+ python_setup
+
local disable_modules=()
use boost || disable_modules+=( "boost" )
use bindist && disable_modules+=( "ecdsa" )
@@ -112,7 +114,7 @@ src_configure() {
tc-export CC CXX AR
- ./configure.py "${myargs[@]}" || die "configure.py failed"
+ ${EPYTHON} configure.py "${myargs[@]}" || die "configure.py failed with ${EPYTHON}"
}
src_test() {
diff --git a/dev-libs/botan/botan-2.18.1-r1.ebuild b/dev-libs/botan/botan-2.18.1-r1.ebuild
index 5f66e51f3aa3..0e5c78c36a50 100644
--- a/dev-libs/botan/botan-2.18.1-r1.ebuild
+++ b/dev-libs/botan/botan-2.18.1-r1.ebuild
@@ -59,6 +59,8 @@ python_check_deps() {
}
src_configure() {
+ python_setup
+
local disable_modules=(
$(usex boost '' 'boost')
$(usex bindist 'ecdsa' '')
@@ -147,7 +149,7 @@ src_configure() {
tc-export CC CXX AR
- ./configure.py "${myargs[@]}" || die "configure.py failed"
+ ${EPYTHON} configure.py "${myargs[@]}" || die "configure.py failed with ${EPYTHON}"
}
src_test() {