summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-08 15:22:28 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-08 15:27:24 -0400
commit9e356729a0b908d7f622199c469826a9ec1efea1 (patch)
tree4352eba0e6622907b9050b7f58e04202e4ddef50 /dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
parentdev-php/pecl-ssh2: add php-7.1 support. (diff)
downloadgentoo-9e356729a0b908d7f622199c469826a9ec1efea1.tar.gz
gentoo-9e356729a0b908d7f622199c469826a9ec1efea1.tar.bz2
gentoo-9e356729a0b908d7f622199c469826a9ec1efea1.zip
dev-php/pecl-ssh2: new v0.13 revision supporting PHP_TARGETS=php7-1.
The SLOT=0 for this package supports php-5.x, while SLOT=7 supports php-7.x. To get them both installed at the same time, we use some weird trickery. Long story short, we need to add a special case to the SLOT=0 ebuild supporting "php7-1" in PHP_TARGETS. The previous commit added php-7.1 support to the SLOT=7 ebuilds, and this commit adds it to the SLOT=0 ebuild. Gentoo-Bug: 603508 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
new file mode 100644
index 000000000000..df76f8cc3b8d
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND="net-libs/libssh2"
+RDEPEND="${DEPEND}"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )
+ php_targets_php7-1? ( dev-php/pecl-ssh2:7 )"
+
+src_prepare(){
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}