summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
new file mode 100644
index 000000000000..df76f8cc3b8d
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND="net-libs/libssh2"
+RDEPEND="${DEPEND}"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )
+ php_targets_php7-1? ( dev-php/pecl-ssh2:7 )"
+
+src_prepare(){
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}