summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-30 21:14:38 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-30 21:26:12 +0200
commit2794d51b40d3d19a96a92f342bad68526ec33286 (patch)
treeaf1c1c6cdda6ef609a09a65057a271b563c31a7d /dev-ruby/json
parentpython-utils-r1.eclass: python_optimize, enable py3.5 logic for pypy3 (diff)
downloadgentoo-2794d51b40d3d19a96a92f342bad68526ec33286.tar.gz
gentoo-2794d51b40d3d19a96a92f342bad68526ec33286.tar.bz2
gentoo-2794d51b40d3d19a96a92f342bad68526ec33286.zip
dev-ruby/json: fix tests for test-unit:2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/json-1.8.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/json/json-1.8.3.ebuild b/dev-ruby/json/json-1.8.3.ebuild
index f28acee7b26e..4c33066a9d1d 100644
--- a/dev-ruby/json/json-1.8.3.ebuild
+++ b/dev-ruby/json/json-1.8.3.ebuild
@@ -52,11 +52,11 @@ each_ruby_compile() {
each_ruby_test() {
JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
+ ${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "pure ruby tests failed"
if [[ $(basename ${RUBY}) != "jruby" ]]; then
JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
+ ${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "ext ruby tests failed"
fi
}