summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/json-1.8.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/json/json-1.8.3.ebuild b/dev-ruby/json/json-1.8.3.ebuild
index f28acee7b26e..4c33066a9d1d 100644
--- a/dev-ruby/json/json-1.8.3.ebuild
+++ b/dev-ruby/json/json-1.8.3.ebuild
@@ -52,11 +52,11 @@ each_ruby_compile() {
each_ruby_test() {
JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
+ ${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "pure ruby tests failed"
if [[ $(basename ${RUBY}) != "jruby" ]]; then
JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
+ ${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "ext ruby tests failed"
fi
}