summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 18:24:47 +0100
committerSam James <sam@gentoo.org>2023-06-26 18:44:54 +0100
commit46a745ed826efe2380bcc26c03166224c360879b (patch)
tree0418e2a3aeab9fd8ca5d3c894ee5c50f78e63559 /dev-util/lttng-ust/lttng-ust-2.13.6.ebuild
parentapp-emacs/clojure-mode: bump to 5.16.1 (diff)
downloadgentoo-46a745ed826efe2380bcc26c03166224c360879b.tar.gz
gentoo-46a745ed826efe2380bcc26c03166224c360879b.tar.bz2
gentoo-46a745ed826efe2380bcc26c03166224c360879b.zip
dev-util/lttng-ust: add 2.13.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.13.6.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.13.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.13.6.ebuild b/dev-util/lttng-ust/lttng-ust-2.13.6.ebuild
new file mode 100644
index 000000000000..1a0f2ce53e3b
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.13.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump the following packages together:
+# dev-util/lttng-modules
+# dev-util/lttng-tools
+# dev-util/lttng-ust
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples numa test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/userspace-rcu-0.12:=
+ numa? ( sys-process/numactl )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-lang/perl )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ pthread_get_name_np # different from pthread_getname_*, not on linux
+ pthread_set_name_np # different from pthread_setname_*, not on linux
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable examples)
+ $(use_enable numa)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}